T O P

Keeping the old world generation as a world type in 1.18

Keeping the old world generation as a world type in 1.18

AutoModerator

Welcome to r/minecraftsuggestions, the place to suggest changes and additions to the game of Minecraft! Before posting an idea, be sure to **read the rules in the sidebar**. One of the most important rules is Rule 4 (Consult the [Frequently Posted Suggestions (FPS) List](https://www.reddit.com/r/minecraftsuggestions/wiki/fps)). We also highly recommend searching if your idea already exists on the subreddit to avoid redundancy. Also, we have [other pages you might want to check](https://www.reddit.com/r/minecraftsuggestions/wiki) and a **[Discord server](https://discord.gg/R37Br7U)** where you can brainstorm your ideas, share and discuss art or just have a casual chat. *Note: This message does not necessarily mean your post has been removed; this is just a friendly reminder :)* *I am a bot, and this action was performed automatically. Please [contact the moderators of this subreddit](/message/compose/?to=/r/minecraftsuggestions) if you have any questions or concerns.*


BlazeNinjaDogg

I love world generation types! The more the better :) It would be cool if Mojang takes time to do this. Since a lot of new mobs spawn depending on these new environments, I think it would take more work than usual, but new world options to tweak is an idea that makes me happy :)


polarigina1

I mean the world gen exists, and they managed to stuff 1.18 world gen in a data pack, I recon they can do this in one of the smaller updates like 1.18.1


BlazeNinjaDogg

Oh that's awesome! I like when solutions end up being easier than you expect :D


Lord_Drakostar

*reckon


Background-Web-484

No no no, recon. Hes going to spy on mojang to see if they are going to do that. Edit: Who gave me this award? What about spying on people is hug-worthy? Also, thx!


polarigina1

Day 11, still outside their office, they haven’t seen me or this post yet.


Background-Web-484

Anything noteworthy?


polarigina1

They haven’t checked my post


Background-Web-484

Lmao, thats some serious intel you got there


chrogleuser5million

I agree, however you could simply move to 1.17/1.16 for the same effect.


Captain_Thrax

Won’t come with new blocks or biomes though


CJPsalm139

Make the world, generate the world, and then update? So like fly in a large circle around spawn so your central area would be default?


SavingsNewspaper2

That just seems like a hassle.


CJPsalm139

True


villager47

Then that's your problem


TrickyLemons

And the subject of the post is one possible solution


Captain_Thrax

That would work, but the center area would still lack the new blocks and the newer regions would still have newer generation. It’s a solution, but it would be best to just... add in a new world option


CJPsalm139

True true


polarigina1

There’s many flaws with that, with the fact that only loaded chunks will have 1.16 features and newer chunks would have 1.18 features. There would be no point


Zombieattackr

This is how I would do it, but there’s also probably an artificial way to generate all those chunks without flying around everywhere. If not, make a program to fly, turn, and fly some more


Foxy02016YT

Bedrock tho


TheGrumpyRavenclaw

I don't see how some features would fit into the old world gen :/ isn't it partially the reason why the underground got deeper so it could fit the new biomes? If the gen is pre-1.18, wouldn't items specific to those biomes be unobtainable?


catball5ive

the first half of 1.17 makes most if not all of the blocks accessible alongside current world generation


TheGrumpyRavenclaw

Not stuff like the Skulk sensor, or items that the Warden might drop and/or protect.


catball5ive

sure, it might not be fully playable, but other world gen options like buffet worlds and floating islands aren’t either. minecraft is at its heart a sandbox game, so making old generation accessible would just be about giving players options.


Realshow

Yeah in general I feel like world generation options should be a bigger part of the game. At the very least I’d like to decide how big specific biomes can get.


[deleted]

[удалено]


Lord_Drakostar

In case you like older world gens? I personally would love to see old world gen types.


[deleted]

[удалено]


Realshow

1.18 is still adding new content besides generation, and there’s gonna come a point where you can’t just casually go back to a years old update for something as basic as this. Also, you can’t do this on Bedrock.


[deleted]

[удалено]


Realshow

You say this when Bedrock already has this kind of feature.


[deleted]

[удалено]


Realshow

It’s directly mentioned in the thread’s description.


[deleted]

[удалено]


meatbeeter69

It would still be cool And it would probably be real easy to implement


CaseyDaGamer

Not on bedrock


Lord_Drakostar

Then you wouldn't have everything, and also "older world generation types" is plural. I'm talking beta


BobKellyLikes

The world gen is roughly the same but sometimes a giant mountain will be dropped onto a jungle or something. If they want to bring back old world gen option it should be Beta 1.7 or release 1.6.


PolarMammoth3

I’m just imagining a blocky helicopter dropping a mountain on a jungle.


Napero44

Meh, someone will probably make a data pack for that.


alpaca1yps

Ctrl on bedrock would the world types be changed from "flat, infinite, old" to "flat, infinite, old, small" or "flat, infinite, old, older" if they did that for bedrock too?


Total_Calligrapher77

OMG! Nice idea!


RatedTemOuttaTem

wtf are all these asshats on about? that's a great idea. Not all computers are able to handle a 384 block world height, and it's already been proven that the new blocks and items can fit into the old world


vyquad37000

i still want the beta 1.7 world gen


Sluin-Plays

yes, If they don't improve the performance this would be the only way for servers to keep running


BunnyboyCarrot

Just keep playing in 1.17? Either you come with or get off the bus.


anthrobeetle451

But then you don't get new blocks in future updates. Sure you might not get all the 1.18 blocks, but when 1.19 comes out, some people may want any new blocks in the update, but still don't want to use the 1.18 cave generation.


[deleted]

[удалено]


Realshow

The old Nether still exists unchanged, it just coexists alongside other biomes now. This is a game about creativity, let people have options.


Lord_Drakostar

Because the new generation's mountains might not be to everyone's liking? When 1.16 came out people could use 1.15. When 1.18 comes out 1.17 won't have the all the features.


[deleted]

[удалено]


Lord_Drakostar

They're not removing those, and no I just think it could be neat to not have mountains, maybe in cases of low world height.


[deleted]

[удалено]


Capable_Breadfruit

I mean. Mountains look cook but they're also going to cause so lag on lower end devices. Old generation would be more for those like me with lower end devices in 1.17


Lord_Drakostar

In cases of having lower world height sure


[deleted]

[удалено]


Lord_Drakostar

Frame rate purposes? Expanding world height was ridiculous from the beginning, cubic chunks would have been the best solution.


sadpeei

New mountains only go up to 256


Lord_Drakostar

Even so, in building cases


[deleted]

[удалено]


CosmicLightning

Mods Don't continue up all the way through to the updates. 2nd, you're suggesting people to rely on a 3rd party user that is likely going to stop working on a mod after a year, then they are back to square one. So get outta here with this useless mindset and sentiment.


BunnyboyCarrot

Alright, calm down. Its a game. The thing is that it doesnt make sense from a game dev standpoint to improve a feature of a game just to keep the unimproved version in. Minecraft already offers support for old versions. So either you get used to the new features, or stay with an old update you like. Not to mention that future generation updates would have to update both generation types, which would make an update take longer and cause more bugs.


EpicNarwhal23_

thats their problem. its the same thing with people that stay on 1.8 for combat. if you dont like the new feature that much and choose to stay in the old edition, its your problem. if you want 1.19, deal with the new generation


Lawice2

Meh


CJPsalm139

***+1! Remember to post to the*** [***feedback site!***](https://feedback.minecraft.net/hc/en-us)


EpicNarwhal23_

old world type on bedrock doesnt mess with generation and only changes the size of the world. its old as a reference to the restricted size of the old console editions


Captain_Thrax

It’s old as a reference to the classic Minecraft Pocket Edition worlds which were smaller due to the lower capabilities of early-gen mobile devices


Eightyseven8787

You could join the mcps3 community ;) please... we're very lonely...


pentagonal_cp

Sounds like a good thing to do.


CelticTexan749

I agree that this should be done I even thought of suggesting something like this


polarigina1

I was surprised no one suggested this already


Chicken_Noob_Man

I am very much not up to date. Are we already talking about 1.18? 1.17 part 1 only comes out tomorrow. Is 1.18 the part 2?


DevJackTGG

It will probably have it in list but i feel it’s a feature like oh let me disable eye of Enders or something but I see what you mean also maybe adding bedrock or something to old gen or even adding it under


Minecraftpro1025

The olde world type basically makes the world smaller, but great idea never the less


shadowmastergt

Nothing some good ol sexy bodacious omega brained mods can do. Man minecraft mods are so good they are comparable to big bouncy tits ngl


acemccrank

Thing is, it is possible to do this with datapacks as-is. You can load up one of the snapshots that had the bigger heights and put in a datapack with, say, 1.16 generation and it will work. From a technical standpoint to the end user, especially the end user that may want to run their own server, keeping a datapack makes more sense than a setting that can, from transfer to transfer, cause issues.


shokmegredditi

Now that’s a good idea hugz for you


Glowing0v3rlord

I like this, also this could be a compatibility bridge between pre-1.18 and post-1.18, just setting worlds made before 1.18 as this old world type so there are no/less generation hassles.


Ramble21_Gaming

You just invented 1.18.1


lolgeny

I mean, already possible by using a data pack...


arthurguillaume

i don't think that's possible cause in future update a lot of new blocks won't appear in "legacy generation" so i don't see why someone would want to have the old gen if it's to only have access to 25% of the new features \+ that should be a mod the time the dev spend on the game is very important


Forawir

That would generate many conflicts with the world generation function, although many if they want it, it would be quite difficult, unless it is optional to choose the 2 types of different generation, but mixing the things of the new with the old I do not think it is possible , especially due to the new height system, etc. sorry my bad english


rickyybrez

Why would you even want boring caves


Justaradomguy1234

So that potatoes can somewhat play 1.18.


_fajfaj_

just play older version